((OTRS)) Community Edition System Requirements

As a web-based solution, ((OTRS)) Community Edition and the OTRS::ITSM module can be used flexibly on different platforms. The most frequently chosen one is based on the Linux server operating system.

For ((OTRS)) Community Edition, the web server and Perl must be installed on the same machine, whereas the database backend can be installed locally or on an alternate host.

Client

Browser: We recommend to us a modern web browser and always use the latest version of your browser because it has the best JavaScript and rendering performance. Dramatical performance varieties between the used browsers can occur with big data or big systems. We are happy to consult you on that matter.

This browsers are not supported:

  • Internet Explorer vor Version 11
  • Firefox vor Version 31
  • Safari vor Version 6

Server Hardware

  • We recommend using a machine with at least a 3 GHz Xeon or comparable CPU, 8 GB RAM and a
    256 GB hard drive.
  • A specific system sizing is part of our consulting support services.

Server
Operating System

  • Red Hat Enterprise Linux (RHEL) or CentOS.
  • SUSE Linux Enterprise Server (SLES) or openSUSE.
  • Debian, Ubuntu or other Linux distributions.
  • UNIX derivates, for example, OpenBSD or FreeBSD.

Application
Database

  • MySQL 5.0 or higher
  • Oracle 10g or higher
  • PostgreSQL 9.2 or higher
  • MariaDB

Webserver

  • Apache2 + mod_perl2 or higher (recommended).
  • Web server with CGI support (CGI is not recommended).

Perl

  • Perl 5.16.0 or higher.
  • You need some additional modules which can be installed either with the Perl shell and CPAN or via the package manager of your operating system (rpm, yast, apt-get).

Directory Service (optional)

Active Directory, eDirectory, OpenLDAP, Oracle Internet Directory, DirX Directory Server, Sun ONE Directory Server or any other LDAP compatible directory service.

Mailserver

Microsoft Exchange, Qmail, Lotus Notes, Postfix, Sendmail, Exim or you can use an external email provider.